aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-11-24 19:32:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-11-24 19:32:48 +0100
commit4b2d1dc4dc48c38ac440aafd384e60565d638cf6 (patch)
tree6b9c64d13ebc6c10ebfa6585ae43c0dc08e119e6
parent5ff6e06763fb5df48465298588a2920ae84c5a3a (diff)
downloadguix-4b2d1dc4dc48c38ac440aafd384e60565d638cf6.tar
guix-4b2d1dc4dc48c38ac440aafd384e60565d638cf6.tar.gz
gnu: bless: Adjust to zlib static output.
* gnu/packages/bioinformatics.scm (bless)[inputs]: Add ZLIB:STATIC. [arguments]: Adjust #:make-flags accordingly.
-rw-r--r--gnu/packages/bioinformatics.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b09a0f7532..026527cd36 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1243,7 +1243,7 @@ confidence to have in an alignment.")
'(#:tests? #f ;no "check" target
#:make-flags
(list (string-append "ZLIB="
- (assoc-ref %build-inputs "zlib")
+ (assoc-ref %build-inputs "zlib:static")
"/lib/libz.a")
(string-append "LDFLAGS="
(string-join '("-lboost_filesystem"
@@ -1286,6 +1286,7 @@ confidence to have in an alignment.")
("boost" ,boost)
("sparsehash" ,sparsehash)
("pigz" ,pigz)
+ ("zlib:static" ,zlib "static")
("zlib" ,zlib)))
(supported-systems '("x86_64-linux"))
(home-page "https://sourceforge.net/p/bless-ec/wiki/Home/")