aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-02 20:13:39 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 17:44:14 +0100
commit36c90dda38b5324530dc2d09b66569ed6f8541a3 (patch)
treeda3cd4402dc3f973e2ca76839ed187b24a8d69f6
parent8aaec042d4a7cff68c219443517b55b1d9f0ee9c (diff)
downloadguix-36c90dda38b5324530dc2d09b66569ed6f8541a3.tar
guix-36c90dda38b5324530dc2d09b66569ed6f8541a3.tar.gz
gnu: Add python-pywavelets.
* gnu/packages/python.scm (python-pywavelets, python2-pywavelets): New public variables.
-rw-r--r--gnu/packages/python.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b0edaf906f..570cfb65e2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4170,6 +4170,49 @@ a front-end for C compilers or analysis tools.")
(define-public python2-pycparser
(package-with-python2 python-pycparser))
+(define-public python-pywavelets
+ (package
+ (name "python-pywavelets")
+ (version "1.0.1")
+ (home-page "https://github.com/PyWavelets/pywt")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyWavelets" version))
+ (sha256
+ (base32
+ "1p3qv2v66ghnqrb1f98wyyhp9dz71jwcd6kfpsax65sfdpiyqp1w"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:modules ((ice-9 ftw)
+ (srfi srfi-1)
+ (srfi srfi-26)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (let ((cwd (getcwd))
+ (libdir (find (cut string-prefix? "lib." <>)
+ (scandir "build"))))
+ (with-directory-excursion (string-append cwd "/build/" libdir)
+ (invoke "nosetests" "-v" "."))))))))
+ (native-inputs
+ `(("python-matplotlib" ,python-matplotlib) ;for tests
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (synopsis "Wavelet transforms in Python")
+ (description
+ "PyWavelets is a library for wavelet transforms in Python. Wavelets are
+mathematical basis functions that are localized in both time and frequency.
+Wavelet transforms are time-frequency transforms employing wavelets. They are
+similar to Fourier transforms, the difference being that Fourier transforms are
+localized only in frequency instead of in time and frequency.")
+ (license license:expat)))
+
+(define-public python2-pywavelets
+ (package-with-python2 python-pywavelets))
+
(define-public python-xcffib
(package
(name "python-xcffib")