aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-02 18:08:42 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-03 17:44:13 +0100
commit0e02e8193686bce4099da37ede0b1ff3055f2264 (patch)
treede762d594bd9ab4b177af7317315388140bbbf98
parenta8fdca11d85296b4df1b60a0c8ce4e33c92759af (diff)
downloadguix-0e02e8193686bce4099da37ede0b1ff3055f2264.tar
guix-0e02e8193686bce4099da37ede0b1ff3055f2264.tar.gz
gnu: python-geventhttpclient: Fix test failure.
* gnu/packages/python-web.scm (python-geventhttpclient)[arguments]: Add "--import-mode=append" to pytest invokation.
-rw-r--r--gnu/packages/python-web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f05047bb9c..a5b4b7578d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1765,7 +1765,10 @@ library.")
(add-after 'install 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
- (invoke "py.test" "src/geventhttpclient/tests" "-v")
+ (invoke "py.test" "src/geventhttpclient/tests" "-v"
+ ;; Append the test modules to sys.path to avoid
+ ;; namespace conflict which breaks SSL tests.
+ "--import-mode=append")
#t)))))
(native-inputs
`(("python-pytest" ,python-pytest)))