aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-12-09 23:08:12 -0500
committerLudovic Courtès <ludo@gnu.org>2017-12-11 17:14:36 +0100
commitfbc60db895fb665d1c0a5281972f9894997ada91 (patch)
treeff956876df5085978110212ccb8de379a489b976
parent9faa46ee48d12bf55355805a84a7c533f904a39d (diff)
downloadguix-fbc60db895fb665d1c0a5281972f9894997ada91.tar
guix-fbc60db895fb665d1c0a5281972f9894997ada91.tar.gz
gnu: Add emacs-grep-a-lot.
* gnu/packages/emacs.scm (emacs-grep-a-lot): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d5142d7ac0..6f4f8a7ec2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1976,6 +1976,26 @@ keep pressing the key until it selects what you want. There's also
column by drawing a thin line down the length of the editing window.")
(license license:gpl3+)))
+(define-public emacs-grep-a-lot
+ (package
+ (name "emacs-grep-a-lot")
+ (version "1.0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ZungBang/emacs-grep-a-lot.git")
+ (commit "9f9f645b9e308a0d887b66864ff97d0fca1ba4ad")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1f8262mrlinzgnn4m49hbj1hm3c1mvzza24py4b37sasn49546lw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ZungBang/emacs-grep-a-lot")
+ (synopsis "Enables multiple grep buffers in Emacs")
+ (description
+ "This Emacs package allows managing multiple grep buffers.")
+ (license license:gpl3+)))
+
(define-public emacs-inf-ruby
(package
(name "emacs-inf-ruby")