aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Meyer <mark@ofosos.org>2018-09-14 22:58:29 +0200
committerGábor Boskovits <boskovits@gmail.com>2018-10-10 11:10:46 +0200
commite7cdd311ae2696713da59a4f27614a246ca0f58a (patch)
tree16963fe2313cb2325455aef53ea21490b2925eae
parent5ff15b86fcd2eae7d9f16f45597db0dce5ee5943 (diff)
downloadguix-e7cdd311ae2696713da59a4f27614a246ca0f58a.tar
guix-e7cdd311ae2696713da59a4f27614a246ca0f58a.tar.gz
gnu: mlt: Prepare for kdenlive.
* gnu/packages/video.scm (mlt): Update to 6.10.0. [inputs]: Add frei0r-plugins, gdk-pixbuf, gtk+-2, qtbase,qtsvg. [make-flags]: Add "CXX=g++ -std=gnu++11". Co-authored-by: Gábor Boskovits <boskovits@gmail.com> Signed-off-by: Gábor Boskovits <boskovits@gmail.com>
-rw-r--r--gnu/packages/video.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2f6a89e14d..3e191ef6da 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -29,6 +29,8 @@
;;; Copyright © 2018 Brendan Tildesley <brendan.tildesley@openmailbox.org>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2018 Mark Meyer <mark@ofosos.org>
+;;; Copyright © 2018 Gábor Boskovit <boskovits@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1942,7 +1944,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(define-public mlt
(package
(name "mlt")
- (version "6.4.1")
+ (version "6.10.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mltframework/mlt/"
@@ -1950,7 +1952,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "10m3ry0b2pvqx3bk34qh5dq337nn8pkc2gzfyhsj4nv9abskln47"))
+ "1zzdj1g3g24q6v8hd0v34lv0pkh37a13fhjpl44h1ffi00mz3577"))
(modules '((guix build utils)))
(snippet '(begin
;; As of glibc 2.26, <xlocale.h> no longer is.
@@ -1960,7 +1962,7 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
- #:make-flags '("CC=gcc")
+ #:make-flags '("CC=gcc" "CXX=g++ -std=gnu++11")
#:configure-flags
(list "--enable-gpl3"
"--enable-gpl")
@@ -1979,11 +1981,16 @@ from sites like Twitch.tv and pipes them into a video player of choice.")
`(("alsa-lib" ,alsa-lib)
("ffmpeg" ,ffmpeg-3.4)
("fftw" ,fftw)
+ ("frei0r-plugins" ,frei0r-plugins)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("gtk+" ,gtk+-2)
("libxml2" ,libxml2)
("jack" ,jack-1)
("ladspa" ,ladspa)
("libsamplerate" ,libsamplerate)
("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
("sdl" ,sdl)
("sox" ,sox)))
(native-inputs