aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Meyer <mark@ofosos.org>2018-09-22 21:28:25 +0200
committerGábor Boskovits <boskovits@gmail.com>2018-10-10 11:11:14 +0200
commita50f5258c785929a5f77a80e1805b502dd0c78c8 (patch)
tree69875c3299dccacda59d3a8ff0780790245c827e
parente7cdd311ae2696713da59a4f27614a246ca0f58a (diff)
downloadguix-a50f5258c785929a5f77a80e1805b502dd0c78c8.tar
guix-a50f5258c785929a5f77a80e1805b502dd0c78c8.tar.gz
gnu: Add kdenlive.
* gnu/packages/kde.scm (kdenlive): New variable. Co-authored-by: Gábor Boskovits <boskovits@gmail.com> Signed-off-by: Gábor Boskovits <boskovits@gmail.com>
-rw-r--r--gnu/packages/kde.scm83
1 files changed, 82 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index a835f42749..3dfba6d383 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,8 +1,9 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
-;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
+;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
(define-module (gnu packages kde)
#:use-module (guix build-system cmake)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -47,8 +49,87 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages video)
#:use-module (gnu packages xorg))
+(define-public kdenlive
+ (let ((version "18.08.1"))
+ (package
+ (name "kdenlive")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://anongit.kde.org/kdenlive.git")
+ (commit (string-append "v" version))))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (propagated-inputs
+ `(("mlt" ,mlt)))
+ (inputs
+ `(("shared-mime-info" ,shared-mime-info)
+ ("frei0r-plugins" ,frei0r-plugins)
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtsvg" ,qtsvg)
+ ("kparts" ,kparts)
+ ("knotifications" ,knotifications)
+ ("karchive" ,karchive)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kcrash" ,kcrash)
+ ("kguiaddons" ,kguiaddons)
+ ("knewstuff" ,knewstuff)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kfilemetadata" ,kfilemetadata)
+ ("kdoctools" ,kdoctools)
+ ("kdeclarative", kdeclarative)
+ ("qtdeclarative", qtdeclarative)
+ ("qtquickcontrols", qtquickcontrols)
+ ("kiconthemes", kiconthemes)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("kplotting", kplotting)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
+ (qtbase (assoc-ref inputs "qtbase"))
+ (qtdeclarative (assoc-ref inputs "qtdeclarative"))
+ (frei0r (assoc-ref inputs "frei0r-plugins"))
+ (qml "/lib/qt5/qml"))
+ (wrap-program (string-append out "/bin/kdenlive")
+ `("QT_PLUGIN_PATH" ":" prefix
+ ,(map (lambda (label)
+ (string-append (assoc-ref inputs label)
+ "/lib/qt5/plugins/"))
+ '("qtbase", "qtsvg")))
+ `("FREI0R_PATH" ":" =
+ (,(string-append frei0r "/lib/frei0r-1/")))
+ `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
+ (,(string-append qtbase "/lib/qt5/plugins/platforms")))
+ `("QML2_IMPORT_PATH" ":" prefix
+ (,(string-append qtquickcontrols qml)
+ ,(string-append qtdeclarative qml)))))
+ #t)))))
+ (home-page "https://kdenlive.org")
+ (synopsis "Non-linear video editor")
+ (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
+
+Non-linear video editing is much more powerful than beginner's (linear)
+editors, hence it requires a bit more organization before starting. However,
+it is not reserved to specialists and can be used for small personal
+projects.")
+ (license license:gpl2+))))
+
(define-public kdevelop
(package
(name "kdevelop")