aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-10 17:32:53 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-10 17:32:53 +0200
commit903378910e32a6981199a1669e67c46ca9be2187 (patch)
treeffb4b7beed66568245ae82822a08a57ff9f408c6
parent099bb0175f681e5f68dafb8ad973866f31fe515c (diff)
downloadguix-903378910e32a6981199a1669e67c46ca9be2187.tar
guix-903378910e32a6981199a1669e67c46ca9be2187.tar.gz
gnu: Add numlockx.
* gnu/packages/xdisorg.scm (numlockx): New variable.
-rw-r--r--gnu/packages/xdisorg.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c31680b246..c92dbd1784 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1497,3 +1497,27 @@ before the system goes to sleep.")
"Pyperclip is a clipboard module for Python, handling copy/pasting from
the X11 clipboard")
(license license:bsd-3)))
+
+(define-public numlockx
+ (package
+ (name "numlockx")
+ (version "1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; It seems that upstream is gone.
+ (url "https://github.com/rg3/numlockx")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1w49fayhwzn5rx0z1q2lrvm7z8jrd34lgb89p853a024bixc3cf2"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("xorg-server" ,xorg-server)))
+ (home-page "https://github.com/rg3/numlockx")
+ (synopsis "Turns on the numlock key in X11")
+ (description "@command{numlockx} is a tiny program that lets you turn on
+the numlock key in X11. It can be called from the user's initialization files
+to automatically turn it on on login.")
+ (license license:expat)))