aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-10-10 12:16:51 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-10-10 23:04:18 +0200
commit47f9fb18a3b40a702368cc2dd70e3db1c95679f7 (patch)
treeaac1439b22b6bb0549e2f9bf4b955443407d3546
parent3d0fdb34a24dda76130aae3e60743e2191fe3e3d (diff)
downloadguix-47f9fb18a3b40a702368cc2dd70e3db1c95679f7.tar
guix-47f9fb18a3b40a702368cc2dd70e3db1c95679f7.tar.gz
gnu: Add kicad-symbols.
* gnu/packages/engineering.scm (kicad-symbols): New variable.
-rw-r--r--gnu/packages/engineering.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ee524ec78e..0080356494 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -823,6 +823,30 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
render model libraries.")
(license license:lgpl2.0+))))
+(define-public kicad-symbols
+ (package
+ (name "kicad-symbols")
+ (version "5.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KiCad/kicad-symbols.git")
+ (commit version)))
+ (file-name (string-append "kicad-symbols-" version "-checkout"))
+ (sha256
+ (base32
+ "18z5vpdq7hy2mpvm5vz1dz3ra3a5iybavvlzi8q2bmmdb6gsvf64"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; No tests exist
+ (home-page "http://kicad-pcb.org/")
+ (synopsis "Official KiCad schematic symbol libraries for KiCad 5")
+ (description "This package contains the official KiCad schematic symbol
+libraries for KiCad 5.")
+ ;; TODO: Exception: "To the extent that the creation of electronic designs that use 'Licensed Material' can be considered to be 'Adapted Material', then the copyright holder waives article 3 of the license with respect to these designs and any generated files which use data provided as part of the 'Licensed Material'."
+ ;; See <https://github.com/KiCad/kicad-symbols/blob/master/LICENSE.md>.
+ (license license:cc-by-sa4.0)))
+
(define-public linsmith
(package
(name "linsmith")