aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 22:28:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 23:49:13 +0200
commit43c97cceae055fc59ca14ddc5b3475d66f98de37 (patch)
tree378fc28de2eb0f22693dcb4720e24e3eee2f8493
parent47f9fb18a3b40a702368cc2dd70e3db1c95679f7 (diff)
downloadguix-43c97cceae055fc59ca14ddc5b3475d66f98de37.tar
guix-43c97cceae055fc59ca14ddc5b3475d66f98de37.tar.gz
gnu: ranger: More test tweaks.
There's no functional difference between 'make test_pytest' and running 'py.test' directly, but there may be in future. This follows up on commit 14173b3c6765bd8fcb2b12ea28fc27226645c7e1. * gnu/packages/disk.scm (ranger)[arguments]: Use #:test-target to run the (same) tests through 'make'. [native-inputs]: Remove left-over python-flake8 and python-pylint.
-rw-r--r--gnu/packages/disk.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d88dbc8921..2158da6a81 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -528,13 +528,15 @@ Duperemove can also take input from the @command{fdupes} program.")
(build-system python-build-system)
(inputs
`(("w3m" ,w3m)))
- (native-inputs ;for tests
- `(("python-flake8" ,python-flake8)
- ("python-pylint" ,python-pylint)
- ("python-pytest" ,python-pytest)
- ("which" ,which)))
+ (native-inputs
+ `(("which" ,which)
+
+ ;; For tests.
+ ("python-pytest" ,python-pytest)))
(arguments
- '(#:phases
+ '( ;; The 'test' target runs developer tools like pylint, which fail.
+ #:test-target "test_pytest"
+ #:phases
(modify-phases %standard-phases
(add-after 'configure 'wrap-program
;; Tell 'ranger' where 'w3mimgdisplay' is.
@@ -548,9 +550,9 @@ Duperemove can also take input from the @command{fdupes} program.")
`("W3MIMGDISPLAY_PATH" ":" prefix (,w3mimgdisplay)))
#t)))
(replace 'check
- ;; Running 'make test' simply prints 'Ran 0 tests in 0.000s'.
- (lambda _
- (invoke "py.test" "tests"))))))
+ ;; The default check phase simply prints 'Ran 0 tests in 0.000s'.
+ (lambda* (#:key test-target #:allow-other-keys)
+ (invoke "make" test-target))))))
(home-page "https://ranger.github.io/")
(synopsis "Console file manager")
(description "ranger is a console file manager with Vi key bindings. It