aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 20:05:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 22:12:02 +0200
commit4273a7ef65ce3b89b592093e2a07ecb5a9081d7a (patch)
treeff996ecb8d3b47c7cfc53db4b003e7a8d40d63fd
parent8984dbd0deb380f6706d36bc9f1aaa061c0e751a (diff)
downloadguix-4273a7ef65ce3b89b592093e2a07ecb5a9081d7a.tar
guix-4273a7ef65ce3b89b592093e2a07ecb5a9081d7a.tar.gz
gnu: libblockdev: Update to 2.20.
* gnu/packages/disk.scm (libblockdev): Update to 2.20. [license]: Update to match fixed licence headers.
-rw-r--r--gnu/packages/disk.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index a9c355e412..338678b8d1 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -698,14 +698,15 @@ to create devices with respective mappings for the ATARAID sets discovered.")
(define-public libblockdev
(package
(name "libblockdev")
- (version "2.18")
+ (version "2.20")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/storaged-project/libblockdev/releases/download/"
+ (uri (string-append "https://github.com/storaged-project/"
+ "libblockdev/releases/download/"
version "-1/libblockdev-" version ".tar.gz"))
(sha256
(base32
- "1a3kpdr9s6g7nfibazi92i27wbv692b5gm2r24gimis6l6jq4pbh"))))
+ "092snk5jyv48na4d46v1ckiy859zwpb3r0ivnxv3km5vzsp76y7q"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -738,6 +739,4 @@ manipulation of block devices. It has a plugin-based architecture where each
technology (like LVM, Btrfs, MD RAID, Swap...) is implemented in a separate
plugin, possibly with multiple implementations (e.g. using LVM CLI or the new
LVM D-Bus API).")
- ;; XXX: Copying says LGPL2.1, but the source files with license
- ;; information are GPL2+.
- (license license:gpl2+)))
+ (license license:lgpl2.1+)))