aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-12-09 18:48:11 -0500
committerLudovic Courtès <ludo@gnu.org>2017-12-11 17:14:35 +0100
commit397d7980b7947742a1a49fe635503a29b7634e24 (patch)
treef27ec5033f1ef144d82771f4ba9649d5b8148982
parentb0a2dc72451e842f8512ed760c634213c6414b4a (diff)
downloadguix-397d7980b7947742a1a49fe635503a29b7634e24.tar
guix-397d7980b7947742a1a49fe635503a29b7634e24.tar.gz
gnu: Add emacs-ws-butler.
* gnu/packages/emacs.scm (emacs-ws-butler): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d1b5aeeaf6..f5048c3dec 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
+;;; Copyright © 2017 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5958,6 +5959,35 @@ available key bindings that follow C-x (or as many as space allows given your
settings).")
(license license:gpl3+)))
+(define-public emacs-ws-butler
+ (package
+ (name "emacs-ws-butler")
+ (version "0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lewang/ws-butler.git")
+ (commit "323b651dd70ee40a25accc940b8f80c3a3185205")))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1a4b0lsmwq84qfx51c5xy4fryhb1ysld4fhgw2vr37izf53379sb"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("ert-runner" ,ert-runner)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda _
+ (zero? (system* "ert-runner" "tests")))))))
+ (home-page "https://github.com/lewang/ws-butler")
+ (synopsis "Trim spaces from end of lines")
+ (description
+ "This Emacs package automatically and unobtrusively trims whitespace
+characters from end of lines.")
+ (license license:gpl3+)))
+
(define-public emacs-org-edit-latex
(package
(name "emacs-org-edit-latex")