aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-08 16:38:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-09 05:42:14 +0200
commit317e80cead5d8f78ed021069a3ef108d44824f76 (patch)
tree63ed3716c77c1f591ad079ab9bcc1ee9a0a0407c
parentf6ccb95a86ef22ae678e80b0e9a353e5b2404334 (diff)
downloadguix-317e80cead5d8f78ed021069a3ef108d44824f76.tar
guix-317e80cead5d8f78ed021069a3ef108d44824f76.tar.gz
gnu: unison: End all phases with #t.
* gnu/packages/ocaml.scm (unison)[arguments]: End all phases with #t.
-rw-r--r--gnu/packages/ocaml.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0756aecd6d..6b55e84fed 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -820,7 +820,8 @@ libpanel, librsvg and quartz.")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
;; 'unison-fsmonitor' is used in "unison -repeat watch" mode.
- (install-file "src/unison-fsmonitor" bin))))
+ (install-file "src/unison-fsmonitor" bin)
+ #t)))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc (string-append (assoc-ref outputs "doc")
@@ -829,21 +830,19 @@ libpanel, librsvg and quartz.")
;; This file needs write-permissions, because it's
;; overwritten by 'docs' during documentation generation.
(chmod "src/strings.ml" #o600)
- (and (zero? (system* "make" "docs"
- "TEXDIRECTIVES=\\\\draftfalse"))
- (begin
- (for-each (lambda (f)
- (install-file f doc))
- (map (lambda (ext)
- (string-append
- "doc/unison-manual." ext))
- ;; Install only html documentation,
- ;; since the build is currently
- ;; non-reproducible with the ps, pdf,
- ;; and dvi docs.
- '(;;"ps" "pdf" "dvi"
- "html")))
- #t))))))))
+ (invoke "make" "docs"
+ "TEXDIRECTIVES=\\\\draftfalse")
+ (for-each (lambda (f)
+ (install-file f doc))
+ (map (lambda (ext)
+ (string-append "doc/unison-manual." ext))
+ ;; Install only html documentation,
+ ;; since the build is currently
+ ;; non-reproducible with the ps, pdf,
+ ;; and dvi docs.
+ '(;; "ps" "pdf" "dvi"
+ "html")))
+ #t))))))
(home-page "https://www.cis.upenn.edu/~bcpierce/unison/")
(synopsis "File synchronizer")
(description