aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-10-10 11:49:47 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-10 13:48:21 +0200
commit296ad592166841c3b6762bc4e9114d12451498cf (patch)
treed3e79304913eec53c4fe0166c4afdc88670f10be
parenta50f5258c785929a5f77a80e1805b502dd0c78c8 (diff)
downloadguix-296ad592166841c3b6762bc4e9114d12451498cf.tar
guix-296ad592166841c3b6762bc4e9114d12451498cf.tar.gz
gnu: haunt: Make sure Guile-CommonMark and Guile-Reader are always visible.
* gnu/packages/guile.scm (haunt)[arguments]: In 'wrap-haunt' phase, add Guile-Reader and Guile-CommonMark to the search paths.
-rw-r--r--gnu/packages/guile.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1d330668a7..f7baff4718 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1192,13 +1192,15 @@ Guile's foreign function interface.")
#:tests? #f ; test suite is non-deterministic :(
#:phases (modify-phases %standard-phases
(add-after 'install 'wrap-haunt
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
;; Wrap the 'haunt' command to refer to the right
;; modules.
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(site (string-append
- out "/share/guile/site")))
+ out "/share/guile/site"))
+ (deps (list (assoc-ref inputs "guile-reader")
+ (assoc-ref inputs "guile-commonmark"))))
(match (scandir site)
(("." ".." version)
(let ((modules (string-append site "/" version))
@@ -1207,9 +1209,19 @@ Guile's foreign function interface.")
"/site-ccache")))
(wrap-program (string-append bin "/haunt")
`("GUILE_LOAD_PATH" ":" prefix
- (,modules))
+ (,modules
+ ,@(map (lambda (dep)
+ (string-append dep
+ "/share/guile/site/"
+ version))
+ deps)))
`("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,compiled-modules)))
+ (,compiled-modules
+ ,@(map (lambda (dep)
+ (string-append dep "/lib/guile/"
+ version
+ "/site-ccache"))
+ deps))))
#t)))))))))
(native-inputs
`(("pkg-config" ,pkg-config)