aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-10 23:54:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-11 00:01:44 +0200
commit272fc9dca35c06d431e59e68a2a05ed8c2c3ce96 (patch)
tree03011cc2a6fce5df058914b92068ca5a673d405d
parent43abffa1a3f216aa7cffaa748d3453e30f3e8839 (diff)
downloadguix-272fc9dca35c06d431e59e68a2a05ed8c2c3ce96.tar
guix-272fc9dca35c06d431e59e68a2a05ed8c2c3ce96.tar.gz
gnu: tlp: Return #t from phases.
* gnu/packages/linux.scm (tlp)[argument]: Return #t all from phases.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 9b16083eab..344f3ea397 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4250,12 +4250,14 @@ Light is the successor of lightscript.")
(setenv "TLP_SHCPL"
(string-append out "/share/bash-completion/completions"))
(setenv "TLP_MAN" (string-append out "/share/man"))
- (setenv "TLP_META" (string-append out "/share/metainfo")))))
+ (setenv "TLP_META" (string-append out "/share/metainfo"))
+ #t)))
(delete 'check) ; no tests
(add-before 'install 'fix-installation
(lambda _
;; Stop the Makefile from trying to create system directories.
- (substitute* "Makefile" (("\\[ -f \\$\\(_CONF\\) \\]") "#"))))
+ (substitute* "Makefile" (("\\[ -f \\$\\(_CONF\\) \\]") "#"))
+ #t))
(replace 'install
(lambda _
(invoke "make" "install-tlp" "install-man")
@@ -4289,7 +4291,8 @@ Light is the successor of lightscript.")
"pciutils"
"rfkill"
"wireless-tools"))))))
- bin-files)))))))
+ bin-files)
+ #t))))))
(home-page "http://linrunner.de/en/tlp/tlp.html")
(synopsis "Power management tool for Linux")
(description "TLP is a power management tool for Linux. It comes with