aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-10-10 14:48:46 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-10 14:48:46 +0200
commit121f32a104de6d88774c4a819eb40334a618199c (patch)
treedfffae9bd1ab880c706f24442255a3f766d3f012
parent6b009dbfea3e44a66533a5ea41879df669923cff (diff)
downloadguix-121f32a104de6d88774c4a819eb40334a618199c.tar
guix-121f32a104de6d88774c4a819eb40334a618199c.tar.gz
gnu: guile-next: Update to 2.9.1.
* gnu/packages/guile.scm (guile-next): Update to 2.9.1. [native-inputs, arguments]: Remove. [properties]: New field.
-rw-r--r--gnu/packages/guile.scm39
1 files changed, 8 insertions, 31 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f7baff4718..e223edb9fc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -323,39 +323,14 @@ without requiring the source code to be rewritten.")
(package
(inherit guile-2.2)
(name "guile-next")
- (version (git-version "2.99" revision commit))
+ (version "2.9.1")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.savannah.gnu.org/git/guile.git")
- (commit commit)))
+ (inherit (package-source guile-2.2))
+ (uri (string-append "https://alpha.gnu.org/gnu/guile/guile-"
+ version ".tar.xz"))
(sha256
(base32
- "1c2xy5cflg0hws48914rz3z8mdmf8w3lblfic0kxnymcmdv9cbhv"))
- (file-name (git-file-name name version))))
- (native-inputs
- `(("autoconf", autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("gettext" ,gnu-gettext)
- ("texinfo" ,texinfo)
- ("flex" ,flex)
- ,@(package-native-inputs guile-2.2)))
- (arguments
- (substitute-keyword-arguments (package-arguments guile-2.2)
- ((#:phases phases '%standard-phases)
- ;; XXX: The default 'bootstrap' phase tries to execute the
- ;; ./bootstrap directory.
- `(modify-phases ,phases
- (replace 'bootstrap
- (lambda _
- (patch-shebang "build-aux/git-version-gen")
- (invoke "autoreconf" "-vfi")))
- (add-before 'check 'skip-version-test
- (lambda _
- ;; Remove this test that's bound to fail.
- (delete-file "test-suite/tests/version.test")
- #t))))))
+ "0iba93yqn6mvgid0rfsrg4amym36pg9m8cqdplxsy222blrj9gh1"))))
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -363,7 +338,9 @@ without requiring the source code to be rewritten.")
(search-path-specification
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/3.0/site-ccache"
- "share/guile/site/3.0"))))))))
+ "share/guile/site/3.0")))))
+ (properties '((ftp-server . "alpha.gnu.org")
+ (upstream-name . "guile"))))))
(define (make-guile-readline guile)
(package