aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-12-10 10:07:44 -0500
committerLeo Famulari <leo@famulari.name>2018-12-10 13:23:17 -0500
commitfec2c8532d238f75b2d33e2281509d101bd45171 (patch)
treece96826fcabbae04402c973ae990c1ecfb0a2846
parentf21058dc5c423f76d51542f557927d756548e5be (diff)
downloadguix-fec2c8532d238f75b2d33e2281509d101bd45171.tar
guix-fec2c8532d238f75b2d33e2281509d101bd45171.tar.gz
gnu: Borg: Update to 1.1.8.
* gnu/packages/backup.scm (borg): Update to 1.1.8. [source]: Remove obsolete patch. * gnu/packages/patches/borg-respect-storage-quota.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/backup.scm5
-rw-r--r--gnu/packages/patches/borg-respect-storage-quota.patch32
3 files changed, 2 insertions, 36 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 50fc08445f..4f2437befa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -607,7 +607,6 @@ dist_patch_DATA = \
%D%/packages/patches/blast+-fix-makefile.patch \
%D%/packages/patches/blender-newer-ffmpeg.patch \
%D%/packages/patches/boost-fix-icu-build.patch \
- %D%/packages/patches/borg-respect-storage-quota.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/cairo-CVE-2016-9082.patch \
%D%/packages/patches/cairo-setjmp-wrapper.patch \
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index c927a14673..a9d8286702 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -491,15 +491,14 @@ detection, and lossless compression.")
(define-public borg
(package
(name "borg")
- (version "1.1.7")
+ (version "1.1.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
- (patches (search-patches "borg-respect-storage-quota.patch"))
(sha256
(base32
- "1p3zia62vyg9vadkdjzzkzbj4dmgijr7ix5lmhfbxpwy5q9imdgp"))
+ "0qqvcscn1l4y83x4sh3izdpmr8zq38j8chjkpfq4q4d01i470hqb"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/borg-respect-storage-quota.patch b/gnu/packages/patches/borg-respect-storage-quota.patch
deleted file mode 100644
index d23d1ffc01..0000000000
--- a/gnu/packages/patches/borg-respect-storage-quota.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Make sure the client respects the storage quota set by the server:
-
-https://github.com/borgbackup/borg/issues/4093
-
-Patch copied from upstream source repository:
-
-https://github.com/borgbackup/borg/commit/975cc33206e0e3644626fb7204c34d2157715b61
-
-From 975cc33206e0e3644626fb7204c34d2157715b61 Mon Sep 17 00:00:00 2001
-From: Manu <manu@snapdragon.cc>
-Date: Wed, 3 Oct 2018 23:47:36 +0800
-Subject: [PATCH] Add storage_quota for forced_result if set by serve command.
-
----
- src/borg/archiver.py | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/borg/archiver.py b/src/borg/archiver.py
-index 916725e7..279194c1 100644
---- a/src/borg/archiver.py
-+++ b/src/borg/archiver.py
-@@ -4276,6 +4276,7 @@ def get_args(self, argv, cmd):
- result.restrict_to_paths = forced_result.restrict_to_paths
- result.restrict_to_repositories = forced_result.restrict_to_repositories
- result.append_only = forced_result.append_only
-+ result.storage_quota = forced_result.storage_quota
- return result
-
- def parse_args(self, args=None):
---
-2.19.1
-