aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-11 23:27:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 20:10:56 +0100
commitd52680eec04c83c9350ebedebea19f9aa67ac1e9 (patch)
treec9625e51be3eea060fc8f79f263ec7c4b2b9e9fc
parentc4ac237f0898a56bcbb21e739ed4fdd51f9ac66f (diff)
downloadguix-d52680eec04c83c9350ebedebea19f9aa67ac1e9.tar
guix-d52680eec04c83c9350ebedebea19f9aa67ac1e9.tar.gz
gnu: libxml2: Don't reference libxml2.a in the default output.
* gnu/packages/xml.scm (libxml2)[arguments]: Add substitution for libxml2.la.
-rw-r--r--gnu/packages/xml.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index fd4c3fea2c..b85064ed7f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -145,6 +145,12 @@ hierarchical form with variable field lengths.")
(rename-file ar (string-append dst "/"
(basename ar))))
(find-files src "\\.a$"))
+
+ ;; Remove reference to the static library from the .la
+ ;; file such that Libtool does the right thing when both
+ ;; the shared and static variants are available.
+ (substitute* (string-append src "/libxml2.la")
+ (("^old_library='libxml2.a'") "old_library=''"))
#t))))))
(home-page "http://www.xmlsoft.org/")
(synopsis "C parser for XML")