aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2018-12-05 17:44:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-12-06 12:26:30 -0500
commita18f8eaf61dbc359a1ca724c147e4600553247fb (patch)
tree1ae57ff656e5d93a38b6928896dc78f7ab1c34de
parent68464ea259c87cf9e9eec5858f96e0cdf1d4125c (diff)
downloadguix-a18f8eaf61dbc359a1ca724c147e4600553247fb.tar
guix-a18f8eaf61dbc359a1ca724c147e4600553247fb.tar.gz
gnu: arc-theme: Update to 20181022 and fix build.
* gnu/packages/gnome.scm (arc-theme)[version]: Update to 20181022. [source]: Use new fork, change to git-fetch. [inputs]: Remove and move gtk+ to native-inputs. [native-inputs]: Add gtk+, glib:bin, gnome-shell, inkscape, optipng and sassc. [home-page]: Adapt to new fork. [license]: Fix to GPL 3 or later (gpl3+). Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b497b965bc..fe3c8b86ae 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
+;;; Copyright © 2018 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -95,6 +96,7 @@
#:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
#:use-module (gnu packages ghostscript)
+ #:use-module (gnu packages inkscape)
#:use-module (gnu packages ibus)
#:use-module (gnu packages iso-codes)
#:use-module (gnu packages libcanberra)
@@ -151,6 +153,7 @@
#:use-module (gnu packages version-control)
#:use-module (gnu packages virtualization)
#:use-module (gnu packages vpn)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xorg)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1))
@@ -6435,15 +6438,16 @@ functionality and behavior.")
(define-public arc-theme
(package
(name "arc-theme")
- (version "20170302")
+ (version "20181022")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/horst3180/arc-theme"
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/NicoHood/arc-theme.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0igxpngnkf1wpsg872a9jg3c9f5z8afm312yfbillz16mk8w39cw"))))
+ "08951dk1irfadwpr3p323a4fprmxg53rk2r2niwq3v62ryhi3663"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -6454,16 +6458,20 @@ functionality and behavior.")
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("gtk+" ,gtk+)))
+ ("glib" ,glib "bin") ; for glib-compile-resources
+ ("gnome-shell" ,gnome-shell)
+ ("gtk+" ,gtk+)
+ ("inkscape" ,inkscape)
+ ("optipng" ,optipng)
+ ("pkg-config" ,pkg-config)
+ ("sassc" ,sassc)))
(synopsis "A flat GTK+ theme with transparent elements")
(description "Arc is a flat theme with transparent elements for GTK 3, GTK
2, and GNOME Shell which supports GTK 3 and GTK 2 based desktop environments
like GNOME, Unity, Budgie, Pantheon, XFCE, Mate, etc.")
(home-page "https://github.com/horst3180/arc-theme")
;; No "or later" language found.
- (license license:gpl3)))
+ (license license:gpl3+)))
(define-public faba-icon-theme
(package