aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-09 18:13:55 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-09 18:21:10 +0100
commit505a385498d9efeb006fa94ba88098422153cbb5 (patch)
tree6cd40bf256d17adadcea19e59e4a520405e7a5c5
parent8d3f604d9469ff270bf1f95a1da8ad7443e30280 (diff)
downloadguix-505a385498d9efeb006fa94ba88098422153cbb5.tar
guix-505a385498d9efeb006fa94ba88098422153cbb5.tar.gz
gnu: Add go-ipfs.
* gnu/packages/ipfs.scm (go-ipfs): New variable.
-rw-r--r--gnu/packages/ipfs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index f40c1180ae..82ef0ea028 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -20,6 +20,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix git-download)
+ #:use-module (guix download)
#:use-module (guix build-system go)
#:use-module (gnu packages golang))
@@ -210,3 +211,29 @@ powerful and simple.")
(description "A subtool for the @command{gx} package manager for packages
written in Go.")
(license license:expat)))
+
+(define-public go-ipfs
+ (package
+ (name "go-ipfs")
+ (version "0.4.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://dist.ipfs.io/go-ipfs/v" version
+ "/go-ipfs-source.tar.gz"))
+ (sha256
+ (base32
+ "19hfgbyn5sr1bw0cwm3gsjz0w3b3vh3mmkax1906raah30lavj1x"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/ipfs/go-ipfs"
+ #:import-path "github.com/ipfs/go-ipfs/cmd/ipfs"))
+ (home-page "https://ipfs.io")
+ (synopsis "Go implementation of IPFS, a peer-to-peer hypermedia protocol")
+ (description "IPFS is a global, versioned, peer-to-peer filesystem. It
+combines good ideas from Git, BitTorrent, Kademlia, SFS, and the Web. It is
+like a single bittorrent swarm, exchanging git objects. IPFS provides an
+interface as simple as the HTTP web, but with permanence built in. You can
+also mount the world at @code{/ipfs}.")
+ (license license:expat)))