aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2018-12-10 23:20:21 +0100
committerArun Isaac <arunisaac@systemreboot.net>2018-12-11 23:08:37 +0530
commit2165ea1d1c707f664c8db2a82cd38a67e3bce01b (patch)
treee99fd8ece7b2955c8025e17c2204cdfbf01cfa86
parent799f5d0df023480f5514821cf011ec6ca1224237 (diff)
downloadguix-2165ea1d1c707f664c8db2a82cd38a67e3bce01b.tar
guix-2165ea1d1c707f664c8db2a82cd38a67e3bce01b.tar.gz
gnu: Add emacs-sesman.
* gnu/packages/emacs.scm (emacs-sesman): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 13588bf013..a7fbd76571 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12729,3 +12729,29 @@ Emacs.")
rooms. It also provides an API which allows Emacs to seamlessly create
RPC channels with users and other software.")
(license license:gpl3+))))
+
+(define-public emacs-sesman
+ (package
+ (name "emacs-sesman")
+ (version "0.3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vspinu/sesman.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r32f8ma9ddczxrrdz0nadp14j3zmk10q1ch02gb82synkx3xdra"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("make" "test")))
+ (home-page "https://github.com/vspinu/sesman")
+ (synopsis "Session manager for Emacs based IDEs")
+ (description "Sesman provides facilities for session management and
+interactive session association with the current contexts (project, directory,
+buffers). While sesman can be used to manage arbitrary sessions, it primary
+targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
+ (license license:gpl3+)))