aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-02 16:15:12 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-02 16:15:12 +0100
commitb8f924274b1e522e56145b2a4bed844a636aa0c7 (patch)
tree0ecfced6bff9211ef31395604dd0ae59ff0835b0
parent7a0479bb7b8535acad2bf36c7a0b0498a1313422 (diff)
downloadguix-b8f924274b1e522e56145b2a4bed844a636aa0c7.tar
guix-b8f924274b1e522e56145b2a4bed844a636aa0c7.tar.gz
gnu: emacs-desktop-environment: Update to 20190301.
* gnu/packages/emacs-xyz.scm (emacs-desktop-environment): Update to 20190301.
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 36cc005549..86dbfe6d53 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11161,29 +11161,30 @@ autosuggestions with:
(license license:gpl3+)))
(define-public emacs-desktop-environment
- (package
- (name "emacs-desktop-environment")
- (version "0.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/DamienCassou/desktop-environment.git")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1fal3yfmqg10cb53qsf5gsq2gvyz9w16wmlpnpjwjzwnjfn6l73r"))))
- (build-system emacs-build-system)
- (home-page "https://gitlab.petton.fr/DamienCassou/desktop-environment")
- (synopsis "Control your GNU/Linux desktop environment from Emacs")
- (description
- "This package helps you control your GNU/Linux desktop from Emacs.
+ (let ((commit "a9eba14f2b5b8070f78dca839ca8259736e346a6"))
+ (package
+ (name "emacs-desktop-environment")
+ (version (git-version "0.2.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.petton.fr/DamienCassou/desktop-environment")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0x73x5hy7w55jrzy3xvqhk90rrsznmxjqvsvwhh21qznv5w269xz"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.petton.fr/DamienCassou/desktop-environment")
+ (synopsis "Control your GNU/Linux desktop environment from Emacs")
+ (description
+ "This package helps you control your GNU/Linux desktop from Emacs.
With @code{desktop-environment}, you can control the brightness and volume as
well as take screenshots and lock your screen. The package depends on the
availability of shell commands to do the hard work for us. These commands can
be changed by customizing the appropriate variables.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-org-caldav
(package