aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:10:24 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-04 20:33:19 +0000
commitb32225187bcd54749b9d6fcf10c0deaf350775c5 (patch)
treee69b52b79e454553c69835851a29da1f898cf0e1
parent353b7eb8c5e35beb94b4ad7208a0d72704e7c9fb (diff)
downloadguix-b32225187bcd54749b9d6fcf10c0deaf350775c5.tar
guix-b32225187bcd54749b9d6fcf10c0deaf350775c5.tar.gz
gnu: Add ruby-lino.
* gnu/packages/ruby.scm (ruby-lino): New variable.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 521ad35936..5ed1231d58 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1326,6 +1326,31 @@ the GNOME Libxml2 XML toolkit.")
(home-page "https://xml4r.github.com/libxml-ruby")
(license license:expat)))
+(define-public ruby-lino
+ (package
+ (name "ruby-lino")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "lino" version))
+ (sha256
+ (base32
+ "11d29g0fk372b9fcpyr0k6hxm2b4j4igpysmi542hgbbgqgp9cd3"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No included tests
+ (propagated-inputs
+ `(("ruby-hamster" ,ruby-hamster)
+ ("ruby-open4" ,ruby-open4)))
+ (synopsis "Build and execute commands in Ruby")
+ (description
+ "@code{Lino} provides an interface to run external commands. It provides
+an interface to add options as well as managing the standard input, output and
+error streams.")
+ (home-page "https://github.com/tobyclemson/lino")
+ (license license:expat)))
+
(define-public ruby-xml-simple
(package
(name "ruby-xml-simple")