aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:10:34 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-04 20:33:19 +0000
commita714c30f96d8714cfb4a9cc48cfa05ea5ce9a01a (patch)
tree1e1d1077e92350b05d6898c31eb3a8bfb511f8bb
parentb32225187bcd54749b9d6fcf10c0deaf350775c5 (diff)
downloadguix-a714c30f96d8714cfb4a9cc48cfa05ea5ce9a01a.tar
guix-a714c30f96d8714cfb4a9cc48cfa05ea5ce9a01a.tar.gz
gnu: Add ruby-terraform.
* gnu/packages/ruby.scm (ruby-terraform): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5ed1231d58..5cf0cf0ade 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3812,6 +3812,29 @@ of terminal output.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-terraform
+ (package
+ (name "ruby-terraform")
+ (version "0.22.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby-terraform" version))
+ (sha256
+ (base32
+ "13zjkp71cd19j2ds2h9rqwcfr1zdg5nsh63p89l6qcsc9z39z324"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No included tests
+ (propagated-inputs
+ `(("ruby-lino" ,ruby-lino)))
+ (synopsis "Ruby wrapper around the Terraform command line interface")
+ (description
+ "This package provides a Ruby wrapper around the Terraform command line
+interface so that Terraform can be more easily invoked from Ruby code.")
+ (home-page "https://github.com/infrablocks/ruby_terraform")
+ (license license:expat)))
+
(define-public ruby-pstree
(package
(name "ruby-pstree")