aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:20:27 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-04 20:33:22 +0000
commit8ea991e3afafd512830d613fe5e5be14314a8a4c (patch)
tree9e9e8dfd24f0676d1e7b6763f2dd52f7cd3b5a95
parent09e2b0af40f08a2f279d67bc0db3a1a28962405b (diff)
downloadguix-8ea991e3afafd512830d613fe5e5be14314a8a4c.tar
guix-8ea991e3afafd512830d613fe5e5be14314a8a4c.tar.gz
gnu: Add ruby-haml.
* gnu/packages/ruby.scm (ruby-haml): New variable.
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 4cf938f6f5..0b48adfff0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1738,6 +1738,33 @@ failure.")
(home-page "https://github.com/thekompanee/fuubar")
(license license:expat)))
+(define-public ruby-haml
+ (package
+ (name "ruby-haml")
+ (version "5.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "haml" version))
+ (sha256
+ (base32
+ "1q0a9fvqh8kn6wm97fcks6qzbjd400bv8bx748w8v87m7p4klhac"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; No included tests
+ (propagated-inputs
+ `(("ruby-tilt" ,ruby-tilt)
+ ("ruby-temple" ,ruby-temple)))
+ (synopsis "Haml is a Ruby library to generate HTML documents")
+ (description
+ "@acronym{Haml, HTML Abstraction Markup Language} is a layer on top of
+HTML or XML that is designed to express the structure of documents using
+indentation rather than closing tags. It was originally envisioned as a
+plugin for Ruby on Rails, but it can function as a stand-alone templating
+engine.")
+ (home-page "http://haml.info/")
+ (license license:expat)))
+
(define-public ruby-hamster
(package
(name "ruby-hamster")