aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-04 21:57:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-04 23:02:12 +0100
commit84b226c27ee4f3292182b0a8580b2fa5f102f255 (patch)
tree5fde506d962eb3a99cb25264bbc240e97c2d0197
parent5ae458befc803fe357210fef343cf322d9f4bade (diff)
downloadguix-84b226c27ee4f3292182b0a8580b2fa5f102f255.tar
guix-84b226c27ee4f3292182b0a8580b2fa5f102f255.tar.gz
gnu: java-eclipse-jdt-core: Include resources.
* gnu/packages/java.scm (java-eclipse-jdt-core)[arguments]: Add build phases "copy-resources" and "move-sources".
-rw-r--r--gnu/packages/java.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 43ba9d2d17..8dce255f5d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -5948,7 +5948,24 @@ and contributes the Eclipse default text editor.")
(build-system ant-build-system)
(arguments
`(#:tests? #f ; no tests included
- #:jar-name "eclipse-jdt-core.jar"))
+ #:jar-name "eclipse-jdt-core.jar"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'move-sources
+ (lambda _
+ (with-directory-excursion "src/jdtCompilerAdaptersrc/"
+ (for-each (lambda (file)
+ (install-file file (string-append "../" (dirname file))))
+ (find-files "." ".*")))
+ (delete-file-recursively "src/jdtCompilerAdaptersrc/")
+ #t))
+ (add-before 'build 'copy-resources
+ (lambda _
+ (with-directory-excursion "src"
+ (for-each (lambda (file)
+ (install-file file (string-append "../build/classes/" (dirname file))))
+ (find-files "." ".*.(props|properties|rsc)")))
+ #t)))))
(inputs
`(("java-eclipse-core-contenttype" ,java-eclipse-core-contenttype)
("java-eclipse-core-filesystem" ,java-eclipse-core-filesystem)