aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-02-17 17:14:49 +0000
committerChristopher Baines <mail@cbaines.net>2019-03-04 20:33:21 +0000
commit7fe1be1879f0de516dbca7217540606bb81b0da6 (patch)
tree381959a2168cf54354949ac824854e3ee79759fb
parent450a3f7f2b44b5965cf14a2fc95ce1191ae6ab96 (diff)
downloadguix-7fe1be1879f0de516dbca7217540606bb81b0da6.tar
guix-7fe1be1879f0de516dbca7217540606bb81b0da6.tar.gz
gnu: Add libsass.
* gnu/packages/web.scm (libsass): New variable.
-rw-r--r--gnu/packages/web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2500bd0be7..15762f05d4 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
@@ -1248,6 +1249,40 @@ minimum to provide high performance operation.")
;; bundled CuTest framework uses a different non-copyleft license.
(license (list l:asl2.0 (l:non-copyleft "file://test/CuTest-README.txt")))))
+(define-public libsass
+ (package
+ (name "libsass")
+ (version "3.5.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sass/libsass.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0830pjcvhzxh6yixj82x5k5r1xnadjqzi16kp53213icbly0r9ma"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'bootstrap 'set-LIBSASS_VERSION
+ (lambda _
+ (setenv "LIBSASS_VERSION" ,version)
+ #t)))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://sass-lang.com/libsass")
+ (synopsis "SASS Compiler, implemented as a C/C++ library")
+ (description
+ "LibSass is a @acronym{SASS,Syntactically awesome style sheets} compiler
+library designed for portability and efficiency. To actually compile SASS
+stylesheets, you'll need to use another program that uses this library,
+@var{sassc} for example.")
+ (license l:expat)))
+
(define-public sassc
;; libsass must be statically linked and it isn't included in the sassc
;; release tarballs, hence this odd package recipe.