aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:06:41 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit6d71fcdf9ea6536593feadcb2b08a2e2b6b49a08 (patch)
tree6175f8224ed4a6d177b0312d65a1d17319149d93
parent45882aafcb283d1e3ca6caf5e9df410db9f0ab62 (diff)
downloadguix-6d71fcdf9ea6536593feadcb2b08a2e2b6b49a08.tar
guix-6d71fcdf9ea6536593feadcb2b08a2e2b6b49a08.tar.gz
gnu: Add hspec-discover.
* gnu/packages/haskell.scm (hspec-discover): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index aff6931ea0..fa8e07822c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1416,6 +1416,30 @@ responses coming back.")
@uref{https://github.com/sol/hspec-expectations#readme, the README}.")
(license expat)))
+(define-public hspec-discover
+ (package
+ (name "hspec-discover")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/hspec-discover/hspec-discover-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0w3awzbljf4hqhxrjrxqa1lfcclg92bhmq641gz2q80vycspapzx"))))
+ (build-system haskell-build-system)
+ (arguments `(#:haddock? #f)) ; Haddock phase fails because there are no
+ ; documentation files.
+ (inputs `(("ghc-hspec-meta" ,ghc-hspec-meta)))
+ (home-page "http://hspec.github.io/")
+ (synopsis "Automatically discover and run Hspec tests")
+ (description "hspec-discover is a tool which automatically discovers and
+runs Hspec tests.")
+ (license expat)))
+
(define-public ghc-hspec-core
(package
(name "ghc-hspec-core")