aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 01:01:17 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit565f040df469091ffedc31f2d12ac10bf5f341b6 (patch)
tree932e98c48a1ee8c9fb0523477a82a4e49ef850c8
parent2108eac211c44ecaf12bcd8662d757737585677e (diff)
downloadguix-565f040df469091ffedc31f2d12ac10bf5f341b6.tar
guix-565f040df469091ffedc31f2d12ac10bf5f341b6.tar.gz
gnu: ghc-split: Update dependencies.
* gnu/packages/haskell.scm (ghc-split): Update package dependencies for compatibility with new GHC. Replicate Cabal-file patch from Hackage.
-rw-r--r--gnu/packages/haskell.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0a8cb01f6c..dde297d6aa 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1389,15 +1389,22 @@ and high speed.")
".tar.gz"))
(sha256
(base32
- "0xa3j0gwr6k5vizxybnzk5fgb3pppgspi6mysnp2gwjp2dbrxkzr"))))
+ "0xa3j0gwr6k5vizxybnzk5fgb3pppgspi6mysnp2gwjp2dbrxkzr"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; The Cabal file on Hackage is updated, but the tar.gz does not
+ ;; include it. See
+ ;; <https://hackage.haskell.org/package/split-0.2.2/revisions/>.
+ '(substitute* "split.cabal"
+ (("base <4.8") "base <4.9")))))
(build-system haskell-build-system)
(inputs
`(("ghc-quickcheck" ,ghc-quickcheck)))
(home-page "http://hackage.haskell.org/package/split")
- (synopsis
- "Combinator library for splitting lists")
- (description "A collection of various methods for splitting lists into
-parts, akin to the 'split' function found in several mainstream languages.")
+ (synopsis "Combinator library for splitting lists")
+ (description "This package provides a collection of Haskell functions for
+splitting lists into parts, akin to the @code{split} function found in several
+mainstream languages.")
(license bsd-3)))
(define-public ghc-parsec