aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-07-12 16:24:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-27 14:19:33 +0200
commit22305f859b5ce21b46fdca04ca20033ced9ce0e2 (patch)
tree2ba4157e1967317e2119b2c4862cd9489f9aec98
parentd804d0b9eff8e7fcdfe289bcd7e49a0d3aa2a062 (diff)
downloadguix-22305f859b5ce21b46fdca04ca20033ced9ce0e2.tar
guix-22305f859b5ce21b46fdca04ca20033ced9ce0e2.tar.gz
gnu: guile-sdl2: Update to 0.3.0.
* gnu/packages/sdl.scm (guile-sdl2): Update to 0.3.0. [arguments]: Remove "patch-makefile" phase.
-rw-r--r--gnu/packages/sdl.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 202716365b..55ce45ce78 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -484,7 +484,7 @@ sound and device input (keyboards, joysticks, mice, etc.).")
(define-public guile-sdl2
(package
(name "guile-sdl2")
- (version "0.2.0")
+ (version "0.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -492,7 +492,7 @@ sound and device input (keyboards, joysticks, mice, etc.).")
version ".tar.gz"))
(sha256
(base32
- "0yq9lsl17cdvj77padvpk3jcw2g6g0pck9jrchc7n2767rrc012b"))))
+ "0iq6fw213qw292fxhrsg40al7hqyqyh4qpgl0x9rh08y949h2w97"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0")
@@ -504,16 +504,7 @@ sound and device input (keyboards, joysticks, mice, etc.).")
(string-append "--with-libsdl2-ttf-prefix="
(assoc-ref %build-inputs "sdl2-ttf"))
(string-append "--with-libsdl2-mixer-prefix="
- (assoc-ref %build-inputs "sdl2-mixer")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'patch-makefile
- (lambda _
- ;; Install compiled Guile files in the expected place.
- (substitute* '("Makefile")
- (("^godir = .*$")
- "godir = $(moddir)\n"))
- #t)))))
+ (assoc-ref %build-inputs "sdl2-mixer")))))
(native-inputs
`(("guile" ,guile-2.2)
("pkg-config" ,pkg-config)))