aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-03-12 10:04:28 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-03-25 15:00:18 +0100
commit6f8016f4d8a84739ffdc7338bb1bbac5179e3ae3 (patch)
treebff2738a21d3517f6cae12a8749038368b9f1776
parent070e1fe99afce1792cefab88852d800c1567ef19 (diff)
downloadguix-6f8016f4d8a84739ffdc7338bb1bbac5179e3ae3.tar
guix-6f8016f4d8a84739ffdc7338bb1bbac5179e3ae3.tar.gz
gnu: Add ghc-json.
* gnu/packages/haskell.scm (ghc-json): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d48983a81a..d106b8783b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8234,4 +8234,29 @@ handler built in.")
handled safely, this is what you're left with.")
(license license:isc)))
+(define-public ghc-json
+ (package
+ (name "ghc-json")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/json/"
+ "json-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18l5027vc68hnnxrxlnyl59vkkg95a92m1zzms0dqiby2r6pxdcn"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-syb" ,ghc-syb)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-text" ,ghc-text)
+ ("ghc-parsec" ,ghc-parsec)))
+ (home-page "http://hackage.haskell.org/package/json")
+ (synopsis "Serializes Haskell data to and from JSON")
+ (description "This package provides a parser and pretty printer for
+converting between Haskell values and JSON.
+JSON (JavaScript Object Notation) is a lightweight data-interchange format.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here