aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-04-16 01:53:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-04-16 02:18:37 +0200
commit167f0e823e791abe33842478c35b69e94dad0d63 (patch)
tree89dfc89c9d58430575f95638e48bc869cf44b7b5
parentf12fc528a5a016e1a6e02a268263b37c389e1e56 (diff)
downloadguix-167f0e823e791abe33842478c35b69e94dad0d63.tar
guix-167f0e823e791abe33842478c35b69e94dad0d63.tar.gz
gnu: game-development: Use HTTPS where possible.
* gnu/packages/game-development.scm (sfml)[home-page]: Use HTTPS. (physfs)[source, home-page]: Likewise. (aseprite)[home-page]: Likewise. (python-pygame)[home-page]: Likewise.
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 8f5b1fb0da..2d52a8a3d2 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Julian Graham <joolean@gmail.com>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -253,7 +254,7 @@ clone.")
("libjpeg" ,libjpeg)
("libsndfile" ,libsndfile)
("openal" ,openal)))
- (home-page "http://www.sfml-dev.org")
+ (home-page "https://www.sfml-dev.org")
(synopsis "Simple and Fast Multimedia Library")
(description
"SFML provides a simple interface to the various computer components,
@@ -305,7 +306,7 @@ sounds from presets such as \"explosion\" or \"powerup\".")
(source (origin
(method url-fetch)
(uri (string-append
- "http://icculus.org/physfs/downloads/physfs-"
+ "https://icculus.org/physfs/downloads/physfs-"
version ".tar.bz2"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
@@ -318,7 +319,7 @@ sounds from presets such as \"explosion\" or \"powerup\".")
`(("zlib" ,zlib)))
(native-inputs
`(("doxygen" ,doxygen)))
- (home-page "http://icculus.org/physfs")
+ (home-page "https://icculus.org/physfs")
(synopsis "File system abstraction library")
(description
"PhysicsFS is a library to provide abstract access to various archives.
@@ -510,7 +511,7 @@ etc.")
(description "Aseprite is a tool for creating 2D pixel art for video
games. In addition to basic pixel editing features, Aseprite can assist in
the creation of animations, tiled graphics, texture atlases, and more.")
- (home-page "http://www.aseprite.org/")
+ (home-page "https://www.aseprite.org/")
(license license:gpl2+)))
(define-public qqwing
@@ -655,7 +656,7 @@ interface (API).")
("libsmpeg" ,libsmpeg)
("portmidi" ,portmidi)
("v4l-utils" ,v4l-utils)))
- (home-page "http://www.pygame.org")
+ (home-page "https://www.pygame.org")
(synopsis "SDL wrapper for Python")
(description "Pygame is a set of Python modules designed for writing games.
Pygame adds functionality on top of the excellent SDL library. This allows you