aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-01-25 21:37:26 -0500
committerKei Kebreau <kkebreau@posteo.net>2019-01-26 11:04:23 -0500
commitfc9c47bd7cdfd6265681e6b2c48fdb7889672bcc (patch)
tree781befd702154c8fb242c7da3285ec31b16d39d0
parent48dbb1bf2b60d6025a544f4b59b4452088331e09 (diff)
downloadguix-fc9c47bd7cdfd6265681e6b2c48fdb7889672bcc.tar
guix-fc9c47bd7cdfd6265681e6b2c48fdb7889672bcc.tar.gz
gnu: maxima: Patch hardcoded paths.
* gnu/packages/maths.scm: (maxima): Patch hardcoded paths. [arguments]: Add the phase 'patch-paths' to replace references to sed, dirname, and head with direct references to the store. [inputs]: Add sed.
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 66d60639ab..602c696567 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2705,6 +2705,7 @@ to BMP, JPEG or PNG image formats.")
(inputs
`(("gcl" ,gcl)
("gnuplot" ,gnuplot) ;for plots
+ ("sed" ,sed)
("tk" ,tk))) ;Tcl/Tk is used by 'xmaxima'
(native-inputs
`(("texinfo" ,texinfo)
@@ -2727,6 +2728,17 @@ to BMP, JPEG or PNG image formats.")
#:make-flags (list "TMPDIR=/tmp")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((sed (string-append (assoc-ref inputs "sed") "/bin/sed"))
+ (coreutils (assoc-ref inputs "coreutils"))
+ (dirname (string-append coreutils "/bin/dirname"))
+ (head (string-append coreutils "/bin/head")))
+ (substitute* "src/maxima.in"
+ (("sed ") (string-append sed " "))
+ (("dirname") dirname)
+ (("head") head))
+ #t)))
(add-before 'check 'pre-check
(lambda _
(chmod "src/maxima" #o555)