aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 16:43:32 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-29 16:09:54 +0000
commitecb172a0152304aeba134ffb03e207469258d206 (patch)
treedb32e15fd258850b46377327a70696aae5e059a5
parentf40c5b160c3f2959ff4935d81510147643d223b3 (diff)
downloadguix-ecb172a0152304aeba134ffb03e207469258d206.tar
guix-ecb172a0152304aeba134ffb03e207469258d206.tar.gz
gnu: Add ruby-jaro-winkler.
Required for ruby-rubocop. * gnu/packages/ruby.scm (ruby-jaro-winkler): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cb6a70bea6..dbb39563bb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3331,6 +3331,29 @@ when working with Ruby code.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-jaro-winkler
+ (package
+ (name "ruby-jaro-winkler")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jaro_winkler" version))
+ (sha256
+ (base32
+ "1zz27z88qznix4r65gd9h56gl177snlfpgv10b0s69vi8qpl909l"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (synopsis "Ruby implementation of Jaro-Winkler distance algorithm")
+ (description
+ "@code{jaro_winkler} is an implementation of Jaro-Winkler distance
+algorithm. It is written as a C extension and will fallback to a pure Ruby
+implementation on platforms where this is unsupported.")
+ (home-page "https://github.com/tonytonyjan/jaro_winkler")
+ (license license:expat)))
+
(define-public ruby-json
(package
(name "ruby-json")