aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-28 14:53:58 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-29 16:09:54 +0000
commitea24d0fbb035eb0e71d71d827b245a1259772aee (patch)
tree1fbdce41b35f5515cf0504b1bc299ac416bcb108
parent1a1c76f283da90672014ff9aa2c13f4bcf203d74 (diff)
downloadguix-ea24d0fbb035eb0e71d71d827b245a1259772aee.tar
guix-ea24d0fbb035eb0e71d71d827b245a1259772aee.tar.gz
gnu: Add ruby-bump.
Required for ruby-parallel. * gnu/packages/ruby.scm (ruby-bump): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index bf4a2ce559..46ad3bc0a7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -564,6 +564,28 @@ supported: XML Markup and XML Events.")
(home-page "https://github.com/jimweirich/builder")
(license license:expat)))
+(define-public ruby-bump
+ (package
+ (name "ruby-bump")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "bump" version))
+ (sha256
+ (base32
+ "1xinbr9rzh6cj75x24niwgqcnbhdxc68a8bc41lk8xv6fd906fym"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(;; No included tests
+ #:tests? #f))
+ (synopsis "Tool for working with Rubygems")
+ (description
+ "Bump provides commands to manage Rubygem versioning, updating to the
+next patch version for example.")
+ (home-page "https://github.com/gregorym/bump")
+ (license license:expat)))
+
(define-public ruby-rjb
(package
(name "ruby-rjb")