aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:39 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-29 21:35:37 +0000
commite0d524fb90397213a21bb03e66016759d07e15d4 (patch)
tree44fdb5f13b33ee79c6ad77ff765af2f966fb500d
parent35c4840b25af062fafa2d04294a9ec3151efdd0f (diff)
downloadguix-e0d524fb90397213a21bb03e66016759d07e15d4.tar
guix-e0d524fb90397213a21bb03e66016759d07e15d4.tar.gz
gnu: Add ruby-terraform.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 29dc9e7f8b..ac0f68b747 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3661,6 +3661,29 @@ of terminal output.")
;; There is no mention of the "or later" clause.
(license license:gpl2)))
+(define-public ruby-terraform
+ (package
+ (name "ruby-terraform")
+ (version "0.12.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby-terraform" version))
+ (sha256
+ (base32
+ "198q2nmfbyn0x7vs81x4gmxymz0z5k7y7x9v48vi8szqlhm9fp7r"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs `(("ruby-lino" ,ruby-lino)))
+ (synopsis
+ "Wraps the Terraform CLI so that Terraform can be invoked from a Ruby script or Rakefile.")
+ (description
+ "Wraps the Terraform CLI so that Terraform can be invoked from a Ruby script or Rakefile.")
+ (home-page
+ "https://github.com/tobyclemson/ruby_terraform")
+ (license license:expat)))
+
(define-public ruby-pstree
(package
(name "ruby-pstree")