aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 19:28:55 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-29 16:09:54 +0000
commitd4becfa29bc72189c7b35505386f0a6e0606effa (patch)
tree72130905aa1ce1441ec4d655cb9a5bdc6a42c274
parentb9083a2db5564d1da9ac10237e43ff15cd7729f2 (diff)
downloadguix-d4becfa29bc72189c7b35505386f0a6e0606effa.tar
guix-d4becfa29bc72189c7b35505386f0a6e0606effa.tar.gz
gnu: Add ruby-minitest-reporters.
Required for ruby-public-suffix tests. * gnu/packages/ruby.scm (ruby-minitest-reporters): New variable.
-rw-r--r--gnu/packages/ruby.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 61f26d0c45..8de1aa3bf4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2445,6 +2445,51 @@ instance, it provides @code{assert_true}, @code{assert_false} and
(home-page "https://github.com/halostatue/minitest-bonus-assertions")
(license license:expat)))
+(define-public ruby-minitest-reporters
+ (package
+ (name "ruby-minitest-reporters")
+ (version "1.3.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "minitest-reporters" version))
+ (sha256
+ (base32
+ "1a3das80rwgys5rj48i5ly144nvszyqyi748bk9bss74jblcf5ay"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Remove the requirement on Rubocop, as it isn't useful to run, and
+ ;; including it as an input can lead to circular dependencies.
+ (add-after 'unpack 'remove-rubocop-from-Rakefile
+ (lambda _
+ (substitute* "Rakefile"
+ (("require 'rubocop/rake\\_task'") "")
+ (("RuboCop::RakeTask\\.new\\(:rubocop\\)") "[].each"))
+ #t))
+ (add-after 'extract-gemspec 'remove-rubocop-from-gemspec
+ (lambda _
+ (substitute* "minitest-reporters.gemspec"
+ ((".*%q<rubocop>.*") "\n"))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-ansi" ,ruby-ansi)
+ ("ruby-builder" ,ruby-builder)
+ ("ruby-minitest" ,ruby-minitest)
+ ("ruby-ruby-progressbar" ,ruby-ruby-progressbar)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-maruku" ,ruby-maruku)))
+ (synopsis "Enhanced reporting for Minitest tests")
+ (description
+ "@code{minitest/reporters} provides a custom Minitest runner to improve
+how the test state is reported. A number of different reporters are
+available, including a spec reporter, progress bar reporter, a HTML
+reporter.")
+ (home-page "https://github.com/kern/minitest-reporters")
+ (license license:expat)))
+
(define-public ruby-minitest-rg
(package
(name "ruby-minitest-rg")