aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-27 16:42:04 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-29 16:09:54 +0000
commit6acee2d56786e94ffc30dd16448d69a401d2ca40 (patch)
tree9ed50e437816b2e3e7eb262bc893b6897a7a8011
parent9a7dfc73f38144891db1d409db16b46a1779af0e (diff)
downloadguix-6acee2d56786e94ffc30dd16448d69a401d2ca40.tar
guix-6acee2d56786e94ffc30dd16448d69a401d2ca40.tar.gz
gnu: Add ruby-rest-client.
Required for ruby-ast. * gnu/packages/ruby.scm (ruby-rest-client): New variable.
-rw-r--r--gnu/packages/ruby.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fc2c75e134..73d3511675 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3894,6 +3894,52 @@ wrapping them in ANSI escape codes.")
(home-page "https://github.com/sickill/rainbow")
(license license:expat)))
+(define-public ruby-rest-client
+ (package
+ (name "ruby-rest-client")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rest-client" version))
+ (sha256
+ (base32
+ "1hzcs2r7b5bjkf2x2z3n8z6082maz0j8vqjiciwgg3hzb63f958j"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'remove-unnecessary-development-dependencies
+ (lambda _
+ (substitute* "rest-client.gemspec"
+ ;; Remove rubocop as it's unused. Rubocop also indirectly
+ ;; depends on this package through ruby-parser and ruby-ast so
+ ;; this avoids a dependency loop.
+ ((".*rubocop.*") "\n")
+ ;; Remove pry as it's unused, it's a debugging tool
+ ((".*pry.*") "\n"))
+ #t))
+ (add-before 'check 'delete-network-dependent-tests
+ (lambda _
+ (delete-file "spec/integration/request_spec.rb")
+ (delete-file "spec/integration/httpbin_spec.rb")
+ #t)))))
+ (propagated-inputs
+ `(("ruby-http-cookie" ,ruby-http-cookie)
+ ("ruby-mime-types" ,ruby-mime-types)
+ ("ruby-netrc" ,ruby-netrc)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-webmock", ruby-webmock-2)
+ ("ruby-rspec", ruby-rspec)))
+ (synopsis "Simple HTTP and REST client for Ruby")
+ (description
+ "@code{rest-client} provides a simple HTTP and REST client for Ruby,
+inspired by the Sinatra microframework style of specifying actions:
+@code{get}, @code{put}, @code{post}, @code{delete}.")
+ (home-page "https://github.com/rest-client/rest-client")
+ (license license:expat)))
+
(define-public ruby-contest
(package
(name "ruby-contest")