aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:41 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-30 01:28:30 +0000
commit5f628cac790d0d8a1607a421f3a7e46a33663000 (patch)
tree024323f9d473d77ad7a7df0251c6373ca827ac5a
parent028dfec4e9dabcedf3c40ee6afab1cae0a9bd53c (diff)
downloadguix-5f628cac790d0d8a1607a421f3a7e46a33663000.tar
guix-5f628cac790d0d8a1607a421f3a7e46a33663000.tar.gz
gnu: Add ruby-omniauth.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9e284b64a9..191afe7b08 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1101,6 +1101,31 @@ complexity.")
(home-page "http://github.com/intridea/oauth2")
(license license:expat)))
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1p16h1rp8by05k8gfw17xjhgwp60dk8qmj1xalv1n23kmxfsxb1x"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A generalized Rack framework for multiple-provider authentication.")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider authentication.")
+ (home-page
+ "https://github.com/omniauth/omniauth")
+ (license license:expat)))
+
(define-public ruby-open4
(package
(name "ruby-open4")