aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:25 +0000
committerChristopher Baines <mail@cbaines.net>2019-01-29 21:38:31 +0000
commit0c27262d17b002b4fc93ca2d69ddb13e01acf1a4 (patch)
tree1f5efcf56c85e33368b888665638163a9c2030e0
parente8d61a43ab71767919f964ffec612bd03598d20a (diff)
downloadguix-0c27262d17b002b4fc93ca2d69ddb13e01acf1a4.tar
guix-0c27262d17b002b4fc93ca2d69ddb13e01acf1a4.tar.gz
gnu: Add ruby-jwt.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8ae2662277..88cea894dc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3821,6 +3821,27 @@ a native C extension.")
(home-page "https://flori.github.com/json")
(license license:ruby)))
+(define-public ruby-jwt
+ (package
+ (name "ruby-jwt")
+ (version "1.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jwt" version))
+ (sha256
+ (base32
+ "124zz1142bi2if7hl5pcrcamwchv4icyr5kaal9m2q6wqbdl6aw4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "A pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (description
+ "This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (home-page "http://github.com/jwt/ruby-jwt")
+ (license license:expat)))
+
;; Even though this package only provides bindings for a Mac OSX API it is
;; required by "ruby-listen" at runtime.
(define-public ruby-rb-fsevent