aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:57:58 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:30 +0000
commite7b615fb4f200af838b98718060e2d17a8a0f098 (patch)
treedd8bf439f91e515e8acec26d1f45d19cc1e03076
parenta2842cd6cf1781fc538524abdf755e2b9aa58a42 (diff)
downloadguix-e7b615fb4f200af838b98718060e2d17a8a0f098.tar
guix-e7b615fb4f200af838b98718060e2d17a8a0f098.tar.gz
gnu: Add ruby-unicode-display-width.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f828a869fb..31ad2ddd63 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7395,3 +7395,25 @@ https://github.com/flavorjones/loofah-activerecord).")
"")
(home-page "")
(license license:expat)))) ;?
+
+(define-public ruby-unicode-display-width
+(package
+ (name "ruby-unicode-display-width")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "unicode-display_width" version))
+ (sha256
+ (base32
+ "194d70pfxq4d7rrk0vsk1dvj46ns2f350308khi7q5cvnmg3h1xs"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; test data not included in gem.
+ (synopsis
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (description
+ "[Unicode 1.1.0] Determines the monospace display width of a string using EastAsianWidth.txt, Unicode general category, and other data.")
+ (home-page
+ "http://github.com/janlelis/unicode-display_width")
+ (license license:expat)))