aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:02:25 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:32 +0000
commitd9d1dcb42613b9128b197b3a332b6f6a75361d9d (patch)
tree0695674ef0f1910969f9cd0c487d190854744a31
parent6fe15aa4ed5a71c39b9c27eb5bb6ac40a945f77a (diff)
downloadguix-d9d1dcb42613b9128b197b3a332b6f6a75361d9d.tar
guix-d9d1dcb42613b9128b197b3a332b6f6a75361d9d.tar.gz
gnu: Add ruby-ruby-dep.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 55c32a3c56..55596ebdaa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7585,3 +7585,24 @@ https://github.com/flavorjones/loofah-activerecord).")
(base32
"06cy038xlbi8hcr9nv0c9wvafi7s3d05sdc7ydkv8qndi9bs68l3"))
(patches (search-patches "ruby-listen-3.0.8-patch-gemspec.patch"))))))
+
+(define-public ruby-ruby-dep
+(package
+ (name "ruby-ruby-dep")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "ruby_dep" version))
+ (sha256
+ (base32
+ "12i57gpy0gmkwnd7l6xdjpfw9bygxmgwx4hjwgg4mca2jr7d3g47"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; Do not test to avoid circular dependency with gem_isolator.
+ (synopsis
+ "Creates a version constraint of supported Rubies,suitable for a gemspec file")
+ (description
+ "Creates a version constraint of supported Rubies,suitable for a gemspec file")
+ (home-page "https://github.com/e2/ruby_dep")
+ (license license:expat)))