aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:41:14 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commitd23505d7d32d681b8afb921da236d5dc84131a05 (patch)
tree5becea939972b2084e3f58a7dd5dc233e0dcde8a
parentc731418334b87e58a7f8d280701f14dd561fe884 (diff)
downloadguix-d23505d7d32d681b8afb921da236d5dc84131a05.tar
guix-d23505d7d32d681b8afb921da236d5dc84131a05.tar.gz
gnu: Add ruby-bzip2-ruby.
-rw-r--r--gnu/packages/ruby.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 36692712f6..7dc4d92782 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7728,3 +7728,52 @@ https://github.com/flavorjones/loofah-activerecord).")
"Radius is a powerful tag-based template language for Ruby inspired by the template languages used in MovableType and TextPattern. It uses tags similar to XML, but can be used to generate any form of plain text (HTML, e-mail, etc...).")
(home-page "http://github.com/jlong/radius")
(license #f)))
+
+(define-public ruby-bzip2-ruby
+ ;; Use git reference because gem is out of date.
+ (let ((revision "1")
+ (commit "e58f154624ff2d770e92a70e0d8fb1a9e6564720"))
+ (package
+ (name "ruby-bzip2-ruby")
+ (version (string-append "0.2.7." revision "." commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brianmario/bzip2-ruby.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "072jzd1fm6z0fnc166q7n4h8h4vrb9jhpcl7swh7d0qm4fx4cxvz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"
+ ; #:gem-flags
+ ; (list "--"
+ ; (string-append "--with-bz2-dir="
+ ; (assoc-ref %build-inputs "bzip2")
+ ; "/include/" ))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-gemspec-and-source
+ (lambda _
+ (substitute* "bzip2-ruby.gemspec"
+ (("s.files = `git ls-files`") "s.files = `find *`")
+ (("s.test_files = `git ls-files spec`")
+ "s.files = `find spec`"))
+ ;; Use part of the patch proposed at
+ ;; https://github.com/brianmario/bzip2-ruby/pull/26
+ (substitute* "ext/bzip2/writer.c"
+ (("RBASIC\\(res\\)->klass = rb_cString;")
+ "RBASIC_SET_CLASS(res, rb_cString);"))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec-2)
+ ("ruby-rake-compiler" ,ruby-rake-compiler)))
+ (synopsis "Ruby C bindings to libbzip2.")
+ (description "Ruby C bindings to libbzip2.")
+ (home-page
+ "http://github.com/brianmario/bzip2-ruby")
+ (license #f))))