aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:49:49 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:01 +0000
commitc88feee5866062c9981276cd556a78803b817c97 (patch)
treed16951b3c366e83bf344461e61bc499febaeda37
parent119f894286607903b1239f7d33703369874d1f18 (diff)
downloadguix-c88feee5866062c9981276cd556a78803b817c97.tar
guix-c88feee5866062c9981276cd556a78803b817c97.tar.gz
gnu: Add ruby-backports.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 8f0bc280e7..b1086a3b0a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6486,3 +6486,23 @@ than closing tags. It was originally envisioned as a plugin for Ruby on Rails,
but it can function as a stand-alone templating engine.")
(home-page "http://haml.info/")
(license license:expat)))
+
+(define-public ruby-backports
+ (package
+ (name "ruby-backports")
+ (version "3.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "backports" version))
+ (sha256
+ (base32
+ "0m8jkjh4kymgfipd6yb0zcxlas4x5r60k2c94zkklb1ryma33grc"))))
+ (build-system ruby-build-system)
+ (synopsis
+ "Essential backports that enable many of the nice features of Ruby 1.8.7 up to 2.1.0 for earlier versions.")
+ (description
+ "Essential backports that enable many of the nice features of Ruby 1.8.7 up to 2.1.0 for earlier versions.")
+ (home-page
+ "http://github.com/marcandre/backports")
+ (license license:expat)))