aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:38:56 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commita8dac4eb2bb0b0231deea852d2382468504b9e65 (patch)
treeaf6019eecde7d6da972a24d5a99a8927313957da
parent9797bd11837cf0c442fb9c9f83ba8b1e60fc0b28 (diff)
downloadguix-a8dac4eb2bb0b0231deea852d2382468504b9e65.tar
guix-a8dac4eb2bb0b0231deea852d2382468504b9e65.tar.gz
gnu: Add ruby-sass-spec.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b258a0b648..8cc050d266 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7834,3 +7834,28 @@ https://github.com/flavorjones/loofah-activerecord).")
"Extension for popular TDD and BDD frameworks like \"Cucumber\", \"RSpec\" and \"Minitest\" to make testing commandline applications meaningful, easy and fun.")
(home-page "http://github.com/cucumber/aruba")
(license license:expat)))
+
+(define-public ruby-sass-spec
+ ;; There is no gem published so we package directly from the git repository.
+ (let ((commit "ac3d4160c19543273a8a515b0ec00014e311f329"))
+ (package
+ (name "ruby-sass-spec")
+ (version (string-append "0.8.3-1." (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sass/sass-spec.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0hmi1blvysf6388hmivn9idsn1s7hgi3yma3vzwdcaqjyhjbhsca"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #t)) ; There are no tests, but this is to stop people using
+ ; this gem as it does not install correctly.
+ (synopsis "")
+ (description
+ "")
+ (home-page "")
+ (license license:expat)))) ;?