aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-18 11:21:17 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commita63c4d8ceaf172e4c2759caf7491346378071311 (patch)
treeaabda9d8664d198e85885b01b4b369f4b83ab522
parent9595a23897ecdb48c85aee734f0fa2d125e73cb6 (diff)
downloadguix-a63c4d8ceaf172e4c2759caf7491346378071311.tar
guix-a63c4d8ceaf172e4c2759caf7491346378071311.tar.gz
gnu: Add ruby-rerun.
* gnu/packages/ruby.scm (ruby-rerun): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index dcd2c79ac0..b905cf1323 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8246,3 +8246,26 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/opperator/warden-oauth2")
(license #f)))
+
+(define-public ruby-rerun
+ (package
+ (name "ruby-rerun")
+ (version "0.13.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rerun" version))
+ (sha256
+ (base32
+ "1cskvxk8z8vmfail8na7hj91hs0qnvds9nydj04zi3dbddgnbmvz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-listen" ,ruby-listen)))
+ (synopsis
+ "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
+ (description
+ "Restarts your app when a file changes. A no-frills, command-line alternative to Guard, Shotgun, Autotest, etc.")
+ (home-page "http://github.com/alexch/rerun/")
+ (license license:expat)))