aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 11:54:18 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:02 +0000
commita341335ea55fa823b152e384fd6fa6cb2a66e86b (patch)
tree00cc12cf09b663365ca6cea1c996afe10051cba2
parentf27542a2b7eb1864623503216d0aadbe04c2c0d8 (diff)
downloadguix-a341335ea55fa823b152e384fd6fa6cb2a66e86b.tar
guix-a341335ea55fa823b152e384fd6fa6cb2a66e86b.tar.gz
gnu: Add ruby-mail.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 324c8e6f80..7dbe884f65 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6720,3 +6720,28 @@ minutes of work.
(home-page
"http://github.com/faye/websocket-driver-ruby")
(license license:expat)))
+
+(define-public ruby-mail
+ (package
+ (name "ruby-mail")
+ (version "2.6.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "mail" version))
+ (sha256
+ (base32
+ "0c9vqfy0na9b5096i5i4qvrvhwamjnmajhgqi3kdsdfl8l6agmkp"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; needs more pkgs
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)))
+ (propagated-inputs
+ `(("ruby-mime-types" ,ruby-mime-types)))
+ (synopsis "A really Ruby Mail handler.")
+ (description
+ "This package provides a really Ruby Mail handler.")
+ (home-page "https://github.com/mikel/mail")
+ (license license:expat)))