aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 11:16:21 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commit93abce1c9ea733ad40294189eff363b0c9f055d1 (patch)
tree3e33402c83e72f6185e7ef8968c1ffc0a1766c3f
parent2d32119475a27a5871eea373eca48c672ee05262 (diff)
downloadguix-93abce1c9ea733ad40294189eff363b0c9f055d1.tar
guix-93abce1c9ea733ad40294189eff363b0c9f055d1.tar.gz
gnu: Add ruby-hamster.
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2634a21e50..58dc1d11be 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7916,3 +7916,27 @@ https://github.com/flavorjones/loofah-activerecord).")
"open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their io handles easily.")
(home-page "https://github.com/ahoward/open4")
(license #f)))
+
+(define-public ruby-hamster
+ (package
+ (name "ruby-hamster")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "hamster" version))
+ (sha256
+ (base32
+ "1n1lsh96vnyc1pnzyd30f9prcsclmvmkdb3nm5aahnyizyiy6lar"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-concurrent" ,ruby-concurrent)))
+ (synopsis
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (description
+ "Efficient, immutable, thread-safe collection classes for Ruby")
+ (home-page
+ "https://github.com/hamstergem/hamster")
+ (license license:expat)))