aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:25 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commit84f85c662a26ced61c51397eb5af64d66fddeca9 (patch)
tree434f51a1964f88b5842e90b279c0803703ef2171
parent41a67dbe81900eabb2bba70751af0bed89207e70 (diff)
downloadguix-84f85c662a26ced61c51397eb5af64d66fddeca9.tar
guix-84f85c662a26ced61c51397eb5af64d66fddeca9.tar.gz
gnu: Add ruby-jwt.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ac10348505..9e3313ac3b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8129,3 +8129,24 @@ https://github.com/flavorjones/loofah-activerecord).")
(home-page
"https://github.com/omniauth/omniauth-oauth2")
(license license:expat)))
+
+(define-public ruby-jwt
+ (package
+ (name "ruby-jwt")
+ (version "1.5.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jwt" version))
+ (sha256
+ (base32
+ "124zz1142bi2if7hl5pcrcamwchv4icyr5kaal9m2q6wqbdl6aw4"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (synopsis
+ "A pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (description
+ "This package provides a pure ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.")
+ (home-page "http://github.com/jwt/ruby-jwt")
+ (license license:expat)))