aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-02-05 20:03:41 +0000
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:59 +0000
commit726bb4852811a35016482a0aedd633563bd5ac76 (patch)
tree50ba638df5b76477758189e682f64b2bb24584c5
parent0b16e967a08466c59bd75071c4036ea70dea70b8 (diff)
downloadguix-726bb4852811a35016482a0aedd633563bd5ac76.tar
guix-726bb4852811a35016482a0aedd633563bd5ac76.tar.gz
gnu: Add ruby-omniauth.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index fd5fce064b..56179938b4 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8177,3 +8177,28 @@ https://github.com/flavorjones/loofah-activerecord).")
"This package provides a Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth spec.")
(home-page "http://github.com/intridea/oauth2")
(license license:expat)))
+
+(define-public ruby-omniauth
+ (package
+ (name "ruby-omniauth")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "omniauth" version))
+ (sha256
+ (base32
+ "1msqr4qq7mfdvl3rg89529isrv595hvjpj2gi0say4b8nwqfggmg"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("ruby-hashie" ,ruby-hashie)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis
+ "A generalized Rack framework for multiple-provider authentication.")
+ (description
+ "This package provides a generalized Rack framework for multiple-provider authentication.")
+ (home-page
+ "https://github.com/omniauth/omniauth")
+ (license license:expat)))