aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-02-05 12:01:50 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-18 22:16:03 +0000
commit688be760e03f80a45e43f204a5c8b94db173b621 (patch)
tree0db84a7f188418b2da48ed2d8d904a96bb06ce32
parent0f4245c24933893c2609410b9b8e17bc57c5c1d5 (diff)
downloadguix-688be760e03f80a45e43f204a5c8b94db173b621.tar
guix-688be760e03f80a45e43f204a5c8b94db173b621.tar.gz
gnu: Add ruby-vcr.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 05f4e31b9d..1a21c51d59 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7288,3 +7288,25 @@ https://github.com/flavorjones/loofah-activerecord).")
"Radius is a powerful tag-based template language for Ruby inspired by the template languages used in MovableType and TextPattern. It uses tags similar to XML, but can be used to generate any form of plain text (HTML, e-mail, etc...).")
(home-page "http://github.com/jlong/radius")
(license #f)))
+
+(define-public ruby-vcr
+(package
+ (name "ruby-vcr")
+ (version "3.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "vcr" version))
+ (sha256
+ (base32
+ "1y19gb8vz1rbhx1qhim6kpp0fzksqhd7grb50hmrbjx5h4hc3y0y"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:tests? #f)) ; No Rakefile in gem, and there's likely unpackaged
+ ; dependencies anyway.
+ (synopsis
+ "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
+ (description
+ "Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests.")
+ (home-page "http://vcr.github.io/vcr")
+ (license license:expat)))